aboutsummaryrefslogtreecommitdiff
path: root/devenv.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--devenv.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/devenv.nix b/devenv.nix
new file mode 100644
index 0000000..234bd79
--- /dev/null
+++ b/devenv.nix
@@ -0,0 +1,12 @@
+{
+ pkgs,
+ lib,
+ config,
+ inputs,
+ ...
+}: let
+ dictionaryFile = import ./dictionary.nix {pkgs = pkgs;};
+in {
+ env.DICTIONARY_FILE_PATH = dictionaryFile;
+ languages.rust.enable = true;
+}